Dati e Formule Excel


Inserire dati e formule

Guida excel: dati e formuleIn Excel le formule possono essere costituite da costanti, variabili (Indirizzi di celle), operatori matematici e parentesi tonde. L’utilizzo delle parentesi serve a stabilire le precedenze nell’ esecuzione delle operazioni. Si usano solo parentesi tonde inserite le une all’ interno delle altre.Per inserire una formula, dopo avere inserito i dati nelle celle portiamo il cursore all’ interno della cella in cui vogliamo appaia il risultato e specifichiamo al foglio di calcolo l’operazione da eseguire. In primo luogo bisogna specificare che si sta inserendo una formula e non un dato: per far ciò occorre premettere il segno=. Poi con + si indica che si vuol fare la somma tra il contenuto delle celle, mentre per ottenere la differenza, il prodotto, il rapporto e la potenza si utilizzano i simboli: -, *, /, ^. Se si modificano i dati iniziali i risultati delle cinque operazioni cambiano automaticamente. Il ricalcolo automatico permette di riutilizzare, una volta impostate le formule risolutive, il medesimo foglio di calcolo per un’intera classe di problemi, cioè problemi dello stesso tipo che differiscono solo per i dati iniziali. Le formule non compaiono nel foglio di lavoro che contiene solo i risultati, ma sono evidenziate nella barra della formula. Per sommare più numeri in colonna si procede in questo modo:

  • selezionare, ad esempio, la cella A7;
  • digitare = SOMMA(A1:A6) che indica l’intervallo che comprende tutte le celle dalla A1 alla A6.

In alternativa:

  • selezionare la cella A7;
  • selezionare il bottone somma automatica Σ presente sulla barra degli strumenti standard; nella cella A7 e sulla barra della formula apparirà =SOMMA(A1:A6), un tratteggio visualizzerà sullo schermo le celle il cui contenuto sta per essere sommato;
  • confermare se le celle tratteggiate corrispondono a quelle segnalate. II risultato apparirà immediatamente nella cella A7.

Se invece si desidera sommare solo le prime quattro righe (celle dalla A1 alla A4), allora:

  • selezionare la cella A7;
  • selezionare il bottone somma automatica presente sulla barra degli strumenti standard;
  • selezionare con il mouse le celle dalla A1 alla A4;
  • confermare.

Supponiamo ora di voler sommare gli intervalli da A1 ad A2 e da A4 ad A6:

  • selezionare la cella in cui si vuole appaia il risultato;
  • digitare =somma (A1:A2;A4:A6); (il simbolo “;” e un separatore di intervalli);
  • confermare.

Oppure:

  • selezionare la cella in cui si vuole il risultato;
  • selezionare il bottone Somma automatica;
  • selezionare le celle da A1 ad A2 mediante trascinamento del mouse;
  • mantenere premuto il tasto CTRL e selezionare le celle da A4 ad A6;
  • confermare.

I riferimenti possono riguardare celle contenute nello stesso foglio, celle contenute in fogli diversi della stessa cartella, ma anche di cartelle diverse. Per fare riferimento a celle in altri fogli di lavoro all’ interno della stessa cartella occorre:

  • selezionare la cella del foglio 1 che dovrà contenere la formula;
  • digitare un segno di uguale;
  • fare clic sulla scheda Foglio 2;
  • scegliere la cella e premere Invio.

Tornando al Foglio 1 si troverà inserito il riferimento alla cella del Foglio 2 con la seguente sintassi: =Foglio2!A9. Per fare riferimento a fogli di lavoro in altre cartelle (riferimenti esterni):

  • selezionare la cella del Foglio 1 di Cartel1 che dovrà ospitare la formula e digitare il segno di uguale;
  • fare clic nella finestra di Cartel2 e selezionare il Foglio1;
  • Fare clic sulla cella su cui si vuole fare riferimento e premere Invio.

Tornando al Foglio 1 si troverà il riferimento alla cella del Foglio 1 di Cartel2 con la seguente sintassi:=[Cartel2]Foglio1!$A$9. Se la cartella a cui si fa riferimento è chiusa, appare nel riferimento l’intero percorso fino alla cartella in cui si trovala cartella di lavoro: C:\\Excel\[Cartel2]Foglio1!$A$9.Digitando una formula si può incorrere in errori di sintassi. Il sistema è in grado di riconoscere quelli più frequenti e correggerli autonomamente. Per gli altri l’utente viene avvisato di una sintassi sconosciuta tramite messaggi di errore. Questi messaggi cominciano sempre col simbolo # (cancelletto) e terminano con il punto interrogativo o esclamativo a seconda della maggiore o minore gravità. Alcuni messaggi predefiniti sono:

  1. #DIV/0! (il dividendo è uguale a 0 quindi è impossibile effettuare la divisione);
  2. #NUM! (manca un valore numerico);
  3. #NOME? (il nome utilizzato non esiste);
  4. #RIF! (il riferimento non è valido o è stato cancellato);
  5. #VALORE! (un operando o un argomento di funzione non è corretto);
  6. #N/D? (il dato da utilizzare non è disponibile).

Insieme a queste segnalazioni compare un triangolino in alto a sinistra cliccando sul quale si potrà scegliere tra un menu di azioni relative all’ errore come: Informazioni sull’ errore, Mostra passaggi di calcolo,Ignora errore, Modifica nella barra della formula, Opzioni controllo errori, Mostra barra degli strumenti verifica formule. Quando compaiono una serie di cancelletti che riempiono una cella, Excel avverte che lo spazio non è sufficiente a rappresentare il valore e che occorre allargare la cella.

  1. Primi passi  di Excel
  2. Foglio di lavoro
  3. Righe Celle e Colonne
  4. Formato del Testo
  5. Comandi Barra degli Strumenti
  6. Dati e Formule
  7. Operazioni di copia e spostamento
  8. Funzioni Predefinite
  9. Funzioni del foglio di lavoro
  10. Funzione Conta e Somma SE
  11. La formattazione condizionale
  12. Costruire un Grafico
  13. Filtri, intestazioni e piè di pagina
  14. Stampare Foglio di Calcolo
  15. Trucchi per personalizzare Excel
  16. Calcola rata del mutuo

 

No tags for this post.